Задача на оптимизацию в EXCEL, 11 класс (из серии задач)

3
На упаковочной поточной линии работают четыре сотрудника. Операции упаковки последовательны. Время работы (в мин.) каждого сотрудника на каждой операции представлено в таблице. Необходимо наладить процесс упаковки так, чтобы сократить общее время упаковки (повысить производительность).
Операции
Сотрудники

А
В
С
D

1
9
8
8,5
7

2
8
8,8
8
8

3
8,5
7,5
7
7,4

4
8,8
8
7
7

РЕШЕНИЕ
Математическая модель задачи.
Исходные параметры модели задачи о назначениях
 n –количество сотрудников, m – количество операций
 ai = 1 – единичное количество ресурса Ai (i =1,n) (сотрудники)
 bj = 1 – единичное количество работы Bj (j =1,m)(операции)
 cij – характеристика качества выполнения работы Bj с помощью ресурса Аi.
Искомые параметры
 xij – факт назначения или неназначения сотрудника Аi на операцию Bj:
[ Cкачайте файл, чтобы посмотреть картинку ]
L(X) – общая (суммарная) характеристика качества распределения сотрудников по операциям.
Общий вид матрицы задачи о назначениях

Сотрудники
Операции, B1
Количество сотрудников

B1
B2
B3
B4

A1
c11
c12
C13
c14
1

A2
c21
c22
C23
c24
1

А3
C31
C32
C33
C34
1

A4
C41
C42
C43
C44
1

Количество операций
1
1
1
1
[ Cкачайте файл, чтобы посмотреть картинку ]

Ограничения на переменные задачи.
Очевидно, что все переменные задачи неотрицательные и целые числа: xij 
· 0  и xij – целые.
Кроме того, так как каждый сотрудник может выполнять только одну последовательность операций, должны удовлетворяться следующие ограничения:
другими словами в матрице (xij°) суммы элементов по каждой строке и суммы элементов по каждому столбцу должны быть равны единицам. Это условие означает, что выбор претендентов должен быть таким, чтобы в матрице (xij), представляющей решение задачи, было бы по одной единице в каждой строке и по одной единице в каждом столбце, остальные элементы матрицы должны равняться нулю.
Целевая функция в задаче о назначениях.
Необходимо расставить сотрудников так, чтобы суммарное время упаковки было бы минимальным. Суммарное время вычисляется по формуле:

Окончательная математическая модель задачи записывается так:

при ограничениях:

Решение задачи в Excel.
Экранные формы, задание переменных, целевой функции, ограничений и граничных условий задачи представлены на рис.1, 2, 2, и в табл.1

Рис.1

Формулы экранной формы задачи табл.1

Объект математической модели
Выражение в Excel

Переменные задачи
B18: E21

Формула в целевой ячейке I15
=СУММПРОИЗВ(В9:E12;В18:E21)

Ограничения по строкам в ячейках F18:F21
=СУММ(B18:E18) Копируем в диапазон F18:F21

Ограничения по столбцам
в ячейках B22:E22
=СУММ(В18:В21)
Копируем в диапазон B22:E22

Ограничения и граничные условия задачи

Рис.2

В окне «Параметры» установить«Линейная модель»

Результаты решения задачи:

ВЫВОД.
Получили оптимальное распределение. Таким образом, чтобы сократить общее время упаковки (повысить производительность) надо:
Первую операцию выполняет сотрудник D,
Вторую операцию выполняет сотрудник А;
Третью операцию выполняет сотрудник В;
Четвертую операцию выполняет сотрудник С.

13PAGE 15

13PAGE 14115

Скачать оригинальный файл

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

Adblock
detector